Displaying views in YAKINDU Traceability

After you have set up your project and your environment, various views help you to perform different tasks. Depending on the task at hand, you need a suitable set of views. To support the most common use cases, YT provides a couple of default views in different perspectives:

  • the YT Tracing perspective (default perspective), allowing to work with links and to execute queries,
  • the YT Configuration perspective, allowing to manage configurations, and
  • the YT Analysis perspective, allowing to analyze traceability data.

These perspectives can be opened in any of three ways:

  • via Traceability → Perspective,
  • via the shortcuts to the right of the Eclipse tool bar, if the perspective has been opened before, or
  • via Window → Open Perspective.

Within YT perspectives, the third option will show a list of all YT perspectives. Otherwise you can select the perspectives in a dialog opened with Window → Open Perspective → Other.

Depending on the selected perspective, some views will be opened by default. You can open other views by selecting

  • Window → Show View → YT …

or

  • Window → Show View → Other → YAKINDU Traceability → YT …

in the main menu, where YT … represents the name of the particular view.

YT provides the following views:
  • YT Project Overview
  • YT Dashboard
  • YT Dashboard Details
  • YT Editor
  • YT Explorer
  • YT Favorites
  • YT Issues
  • YT Overview
  • YT Queries
  • YT Query Results
  • YT Search
  • YT Selection History

The individual views will be explained in the subsequent sections in the context of the functionalities they are supporting.

The YT Configuration perspective and most other Eclipse perspectives will open editors in the center area of the Eclipse workbench window. In the YT Tracing and YT Analysis perspectives, the editor area is minimized by default. It will be restored automatically if you open an editor in Eclipse, e.g., by double-clicking on an artifact in the YT Explorer that has an Eclipse editor associated with it. The editor area usually remains visible even if no editor is currently open. However, the YT Tracing and YT Analysis perspectives will automatically minimize the editor area whenever there is no open editor.