Entering preferences for your project

In the preferences you can do some basic configurations necessary to work with YT. The preferences can be opened by navigating to

  • Windows/Linux: Window → Preferences → YAKINDU Traceability
  • Mac: Eclipse → Preferences → YAKINDU Traceability

The preferences page for general YT preferences

Installing a YAKINDU Traceability license

The YAKINDU Traceability trial version comes with an evaluation license that is valid for 30 days. If you want to continue working with YAKINDU Traceability beyond that period of time, you have to acquire a license.

The license manager documentation describes how you can install a license file or configure a license server for floating licenses. To access that documentation, select Help → Help Contents from YAKINDU Traceability’s main menu, then open the YAKINDU License Management documentation.

General preferences for YAKINDU Traceability

  • Configuration storage

The configuration storage preferences allow you to select a configuration file in your workspace. If you do not yet have a configuration file, you can create one in the Add new configuration wizard that you can open by clicking on the link below the selection list.

The configuration itself is described in the Configuration section.

You can start or disable YAKINDU Traceability by selecting or unselecting the checkbox and then press the button for applying the preferences. You need to select a configuration file to be able to start YT.

  • Report templates

The location where report templates can be found is configured here.

  • Snapshots

This preference setting allows you to select the folder in which YT should store model snapshots.

  • TCP server

YT includes a TCP server to interact with some external tools, like Microsoft Word. Its port can be configured here. If the server is not needed it can be disabled here.

  • Preferences export/import

The preferences set on this YAKINDU Traceability page can be imported and exported here.

Preferences for layout and views

YT offers additional configuration options for specific views and also some global settings. To inspect and possibly change these preferences, select Window → Preferences → YAKINDU Traceability → Layout & Views in the main menu.

The preferences page for layout and views

Several YT dialogs offer a „Don't show again” checkbox which prevents them from reappearing when they usually would. The button in the „Dialogs” group resets this setting for all dialogs at once, i.e., all dialogs will show up again. You can then selectively hide them again as before.

The remaining options are described by their label or by a short text below the setting.

Preferences for adapters

Some adapters support their own specific preferences settings. You can see and edit these preferences by selecting Window → Preferences → YAKINDU Traceability → Adapters in the main menu. These preferences will be explained in the adapter-specific subsections in the section Connecting YAKINDU Traceability to various tools. The page will show preferences only of those adapters that are installed in your YT.